IP Service Level Agreement

تکنولوژی IP SLA  انحصارا برای شرکت Cisco  می باشد.از این قابلیت برای مانیتور کردن ترافیک شبکه استفاده می شود.از دیگر مزایای IP SLA  بررسی Performance  میان چند شبکه یا مسیر می باشد.

همچنین IP SLA  می تواند انواع مختلف بسته  را برای چک کردن کارایی و وضعیت Real-Time  مسیر شبیه سازی و تولید کند و اطلاعات کیفیتی هر مسیر یا شبکه را دریافت کند.

اطلاعاتی که IP SLA می تواند بررسی کند شامل:

………..,Response Time , one-way latency , Jitter , packet Loss , voice Quality

IP SLA ،مانیتورینگ را به وسیله تولید و آنالیز ترافیک، برای بررسی کارایی و کیفیت میان دستگاه های شبکه و یا حتی Network Application Server  فراهم میکند.

یکی از پرکاربرد ترین و محبوب ترین ابزار IP SLA  چک کردن وضعیت DHCP Server , DNS Query   و Web Server ها می باشد که با توجه به آنالیز شبکه می تواند تصمیمات حیاتی بر روی شبکه به صورت خودکار اعمال کند که نتیجه آن ایجاد High Availability  می شود.

امروزه بسیاری از شرکت های بزرگ نیاز به اتصال دائم به اینترنت دارند و یا بسیاری از شرکت های دیگر تجارت و فعالیت های تجاریشان وابسته به اینترنت می باشد و قطع شدن آن می تواند ضررهای جبران ناپذیری به همراه داشته باشد.

Track

یک قابلیت روترهای Cisco  است که می تواند با تکنولوژی های مختلفی مانند IP SLA  ادغام شود یا به صورت تنها کار کند.

Track  در واقع یک وضعیت (Down or Up) را در شبکه مشخص می کند.

ما می توانیم Track  را در کنار IP SLA  به کار ببریم تا وضعیت شبکه را لحظه به لحظه و Real Time  چک کرده و با توجه به نتیجه Track  ، IP SLA  می تواند راهکارهای مختلفی را در شبکه اعمال کند.

به عنوان مثال از قابلیت های Track  می توان به چک کردن وجود IP  بر روی Interface روتر  یا وجود Route  خاص و مد نظر در  Routing-Table  یا حتی   And و OR   ای بین Object  های که ما مشخص کرده ایم.

ولی با این همه Track  قدرت چندانی ندارد، البته به تنهایی!!

چرا که Track  می تواند  در کنار IP-SLA  کامل و بی نقص باشد.

بر عکس Track  ابزار IP SLA  کامل و پیشرفته است، ولی به تنهایی کاربرد چندانی ندارد.

 

ما در این مقاله سعی داریم از دو ابزار IP SLA  و Track  در کنار هم استقاده کنیم تا با وجود دو لینک اینترنت نهایت اطمینان پذیری دسترسی (HA) به اینترنت را فراهم کنیم.

 

در این سناریو با توجه به شکل زیر از دو شرکت شاتل و آسیاتک دو لینک اینترنت کرایه کرده ایم.

اینترنت شاتل را به علت Bandwidth بالاتر  و دلایل دیگر به عنوان اینترنت Primary  یا اصلی و آسیاتک را به عنوان اینترنت Backup  یا جایگزین انتخاب کردیم.

ما قصد داریم IP SLA  را به نحوی پیاده سازی کنیم که:

به صورت دائم بسته های ICMP-PING  به مقصد ۸٫۸٫۸٫۸ (DNS-Google) با  Source-IP  ای که شاتل به ما قرض داده به سمت شاتل بفرستم تا وضعیت اینترنت را از این مسیر و دسترس بودن DNS-Google  را چک کنیم تا در صورت قعطی به کمک ابزار policy  ، Track  خاصی یعنی تغییر مسیر اینترنت به آسیاتک به صورت خودکار و حداقل Packet Loss  اعمال شود.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

همان طور که گقته شد ما دو IP  ثابت (Static)  و  Valid  که Routable  در دنیای اینترنت هستند از ISP  ها کرایه کردیم.

 

Shatel-IP valid = 11.90.114.63/32

Asiatech –IP valid = 5.180.220.10/32

این دو IP در روتر سیسکو بر روی Interface Loopback  گذاشته (Set)  شده است.

 

 

 

 

ITNovin.com(config)#interface Loopback0

ITNovin.com(config-if)#description IP-Valid-Shatel

ITNovin.com(config-if)#ip address 11.90.114.63 255.255.255.255

————————————————–

ITNovin.com(config)#interface Loopback1

ITNovin.com(config-if)#description IP-Valid-Asiatech

ITNovin.com(config-if)#ip address 5.180.220.10 255.255.255.255

نکته : IP  ها فرضی و برای مثال می باشند.

همچنین ما دو Default-Route  به سمت ISP  ها نوشتیم که Default-Route   سمت آسیاتک با AD (Distance) 5  در نظر گرفته شده (اینترنت Backup) و Default-Route  به سمت شاتل با AD 1  و Track 100  نوشته شده.

نکته : Default-Route  شاتل تا زمانی در Routing-Table  روتر قرار دارد که Track 100  وضعیت UP  داشته باشد در غیر این صورت این روت ignore  می شود (نادیده گرفته میشود) و Default-Route   آسیاتک در Routing-Table  قرار میگیرد.

 

 

ITNovin.com(config)#ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 track 100

ITNovin.com(config)#ip route 0.0.0.0 0.0.0.0 FastEthernet1/0 5

برای جلوگیری از خطاهای NAT  در هنگام تغییر مسیر در روتر،خط های NAT را این گونه تعریف میکنیم.

 

 

 

 

 

 

ITNovin.com(config)#route-map NAT-path-Shatel permit 2

ITNovin.com(config-route-map)#match ip address 101

ITNovin.com(config-route-map)#match interface FastEthernet0/0

————————————————–

ITNovin.com(config)#route-map NAT-Path-Asiatech permit 2

ITNovin.com(config-route-map)#match ip address 101

ITNovin.com(config-route-map)#match interface FastEthernet1/0

 

نکته : interface FastEthernet 0/0  دست خروجی به سمت شاتل و interface FastEthernet 1/0  دست خروجی به سمت آسیاتک است.

 

 

ITNovin.com(config)#access-list 101 permit ip 192.168.1.0 0.0.0.255 any

نکته : شبکه ۱۹۲٫۱۶۸٫۱٫۰/۲۴  شبکه داخلی می باشد.

 

حال NAT  را اینگونه می نویسیم

 

ITNovin.com(config)#ip nat inside source route-map NAT-Path-Asiatech interface Loopback1 overload

ITNovin.com(config)#ip nat inside source route-map NAT-path-Shatel interface Loopback0 overload

 

وضعیت Interface    های فیزیکی روتر :

 

ITNovin.com(config)#interface FastEthernet0/0

ITNovin.com(config-if)#description TO-Shatel

ITNovin.com(config-if)#ip address 20.20.20.1 255.255.255.252

ITNovin.com(config-if)#ip nat outside

————————————————–

ITNovin.com(config)#interface FastEthernet0/1

ITNovin.com(config-if) #description LAN

ITNovin.com(config-if)#ip address 192.168.1.1 255.255.255.0

ITNovin.com(config-if)#ip nat inside

————————————————–

ITNovin.com(config)#interface FastEthernet1/0

ITNovin.com(config-if)#description TO-Asiatech

ITNovin.com(config-if)#ip address 10.10.10.1 255.255.255.252

ITNovin.com(config-if)#ip nat outside

 

IP SLA Configuration

این تنظیمات بر روی IOS  ورژن ۱۲ صورت گرفته.

 

ITNovin.com(config)#ip sla monitor 10

ITNovin.com(config-sla-monitor)#type echo protocol ipIcmpEcho 8.8.8.8 source-interface Loopback0

ITNovin.com(config-sla-monitor-echo)#request-data-size 500

ITNovin.com(config-sla-monitor-echo)#timeout 3500

ITNovin.com(config-sla-monitor-echo)#frequency 1

 

با این تنظیما ت روتر بسته های Ping  با سایز ۵۰۰ Byte  به مقصد ۸٫۸٫۸٫۸  با Source-IP Loopback 0 با بازه زمانی هر ۱۰ ثانیه با Time-Out 3500 ms  ایجاد میکند.

برای فعال سازی IP SLA  و  زمان کاری آن باید دستور زیر را زد.

 

ITNovin.com(config)#ip sla monitor schedule 10 life forever start-time now

 

حال باید Track  را مامور چک کردن دائم IP SLA  کنیم با دستور زیر.

 

ITNovin.com(config)#track 100 rtr 10

ITNovin.com(config-track)#delay down 20 up 10

 

منظور از Delay  یعنی با تغییر وضعیت IP SLA 10  ، Track  برای تغییر وضعیت به UP ده ثانیه  و تغییر وضعیت به Down بیست ثانیه  تاخیر می اندازد به این علت که در صورت وجود اختلال در شبکه Provider  ها  Track  پی در پی تغییر وضعیت ندهد و باعث پایین آمدن Performance شبکه نشود.

 

نکته مهم:

در صورت قعطی شبکه شاتل Default-Route  آسیاتک فعال می شود و تمامی ترافیک هایی که به مقصد اینترنت باشند روی Default-Route  آسیاتک میرود و حتی بسته های پینگ IP SLA  هم به آسیاتک میرود و جواب برمیگردد و دوباره IP SLA  تغییر وضعیت به  (OK)  می دهد در نتیجه Track  تغییر وضعیت به UP  و Default-Route  شاتل دوباره فعال می شود و این داستان و تغییر وضعیت ها دائم صورت می گیرد.

برای رهایی از این مشکل باید بسته های پینگ IP SLA  به مقصد ۸٫۸٫۸٫۸ را Permanent(دائمی)  به سمت شاتل بفرستیم.

روش اول :

ITNovin.com(config)#Ip route 8.8.8.8 255.255.255.255 20.20.20.2 permanent

این روش اصلا مناسب نیست به این علت که در صورت قعطی شاتل بسته های سرور ها و کلاینت های شبکه داخلی به مقصد ۸٫۸٫۸٫۸ می رود سمت شاتل درصورتی که شاتل قطع می باشد.

روش دوم: استفاده از (Policy Basic Routing (PBR

 

ITNovin.com(config)#route-map PBR permit 2

ITNovin.com(config-route-map)#match ip address 150

ITNovin.com(config-route-map)#set ip next-hop 20.20.20.2

————————————————–

ITNovin.com(config)#access-list 150 permit icmp host 11.90.114.63 host 8.8.8.8

————————————————–

ITNovin.com(config)#ip local policy route-map PBR

 

با این کار بسته های ICMP  که فقط خود روتر به مقصد ۸٫۸٫۸٫۸ می فرستد روت میشود به سمت شاتل حتی در صورت قطع بودن شاتل.

 

 

نکته : پیکربندی IP SLA  و Track  در IOS  ورژن ۱۵ به این صورت می باشد.

ITNovin.com(config)#ip sla 10

ITNovin.com(config-ip-sla)#icmp-echo 8.8.8.8 source-interface Loopback0

ITNovin.com(config-ip-sla-echo)#request-data-size 500

ITNovin.com(config-ip-sla-echo)#timeout 3500

ITNovin.com(config-ip-sla-echo)#frequency 10

————————————————–

ITNovin.com(config)#ip sla schedule 10 life forever start-time now

————————————————–

ITNovin.com(config)#track 100 ip sla 10

ITNovin.com(config-track)#delay down 20 up 10

 

 

verify  کردن IP SLA  :

 

قبل از قعطی شاتل:

 

وضعیت Routing-Table :

 

 

 

 

 

 

 

 

 

 

وضعیت IP SLA  و Track:

 

ITNovin.com#show ip sla monitor statistics

ITNovin.com#show track brief

 

 

 

 

 

 

 

 

بعد از قعطی در شاتل :

 

 

 

 

 

 

 

 

وضعیت IP SLA  و Track بعد از قعطی :

 

 

 

 

 

 

 

از دیگر استفاده های IP SLA :

Leave a Comment